COMMODORE PLUS/4 WORLD
  Home  Search  Games  Tapes  Covers  Cheats  Maps  Software  New Stuff 
 Hall Of Fame  HVTC  Game Endings  Solutions  Remakes  Publications  Magazines  Effects  Top List 
 Members  Groups  Features  Plus/4 Encyclopedia  Hardware  Tools  Options  Forum 
Login
Back to forumReply To This TopicGo to last reply

Posted By

MarkyPlus4
on 2018-01-24
04:48:01
 SD2IEC Issue

Hi to all,

Having issues loading games with the SD2IEC, I have downloaded the
CBM filebrowser from the Future Was 8 Bit, the files are there on the SD card
okay. I then copy a d.64 file onto the card, but when I put it into the SD2IEC,
the game is not there on the Plus 4?

What am I doing wrong here?

Any help would be greatly appreciated

Posted By

MarkyPlus4
on 2018-01-24
04:49:56
 Re: SD2IEC Issue

Just to add, I have formatted the SD card to FAT32, should I be formatting to FAT16?

What files should I see on the SD card.

Thankyou

Marc

Posted By

George
on 2018-01-24
05:14:35
 Re: SD2IEC Issue

I had the problem too.

Some newer cards (with many GB) do not work with my sdiec. Try different SD-Cards.

Posted By

Imperious
on 2018-01-24
06:52:56
 Re: SD2IEC Issue

I hope you have labelled the game disk image .d64 not d.64 as You have written.
Try a .prg file as well. A tip with .prg files is You can completely remove the extension,
the game will load fine without it.

Posted By

MarkyPlus4
on 2018-01-24
08:23:11
 Re: SD2IEC Issue

Thanks for the heads up, I will try a different sd card, I did get the 8gb sd card as a package with the C16/Plus4/Kickstart style case, so I thought it should work.

I will check the file names I am using as well.

Will let you know how it goes.

Thankyou

Marc

Posted By

MarkyPlus4
on 2018-01-24
08:26:52
 Re: SD2IEC Issue

I have just tried to download a program file from the games directory, but I can't open it,
using Windows 10 on computer, what program will open it, tried Microsoft Word, coding looks
like jumbled coding?

Posted By

Imperious
on 2018-01-24
08:51:26
 Re: SD2IEC Issue

c16, plus/4, vic-20, c64 games will run in an emulator on Your PC.
I'm not quite sure what you mean about opening them in Windows?
unless you want to extract the contents of the d64 image.

I hope You have the Filebrowser files in the root directory of the sd card.
Then You can just type
LOAD"FB",8 or LOAD"FB16",8
RUN

To load a d64 you normally select it within the filebrowser program then when it shows the
contents you can usually scroll down to a prg file and run that or
hit the Q key then
LOAD"*",8
RUN

Posted By

MarkyPlus4
on 2018-01-24
10:13:04
 Re: SD2IEC Issue

Thanks for your help Imperious, what I mean is that I click Games above on website, then say go to the game Kikstart, then download file, I can extract file, but I can't open the folder, only in Microsoft Word, not sure what program I need to be able to save, and put that file onto the SD card, if you understand what I mean?

Been using "$" instead of LOAD"*",8. Maybe that's why I can't load the game from the SD card on the Plus 4?

Thankyou

Marc

Posted By

MarkyPlus4
on 2018-01-24
10:14:14
 Re: SD2IEC Issue

Yes, trying to extract the contents of a program file to be able to save onto SD card.

Posted By

MMS
on 2018-01-24
14:57:00
 Re: SD2IEC Issue

I think your problem is, that at the very first time you tried to load the D64 or PRG, you selected the very first program offered by Windows (Microsoft Word), and now it is the default.

How to solve it?
1) Certainly first you need to install (extract) an emulator YAPE, Plus4Emu. Remember where is it
As VICE can emulate different machines, may not start in the mode can handle the Plus/4 files, but it has it's subfolders. Personally I do not like it so much than the other two.

2) In the Windows Explorer find your extracted file. You may RIGHT click on the D64 or PRG file and select "Use with..." or something like that at the bottom of the first group. then you can modify the program associated with the file (I have Hungarian Windows since years, sorry I do not know how it is called exactly in eg. Win10)

3) Select "Other Appplication"

4) if the emulator listed, select this. Plus4emu is not installed, but extracted to a folder, so it will be not listed

5) if not listed, then go to the very bottom of the offerered list and select "other local application", and you link the emulator.EXE from the folder you installled it

6) In both cases check in the box "always want to use the application"

But if you made a Emulator icon on the desktop, you can always directly open and run the PRG and D64 files from the emulator. (discs could be tricky sometimes, if you select performance mode, or 1551, or 1541, some program may work, some others not (fastloaders) )


SD Card issues (maybe not directly linked, but who knows?)
I read on an Amiga topic (SD card and Compactflash based filesystems), that some brand's cards perform much better that the others. Usually the "chipo" nonbranded cards can produce different reading issues, not coming from real memory defects, but some memory areas may react slower to the read request that it should. (so you may install a system to that and looks OK initially, but causes different hangups, etc)

Generally speaking I could conclude that Sandisk was always OK (noone reported a problem with them)
Suprisingly the Kingston (my fav brand) was also mentioned by few guys they had issue with them.
There was a guy who told he always have different problems. When I listed some better ones, and ask which one he had trouble, he told he always using branded ones but did not want to name any problematic one.

Although the topic did not go so deep, based on my past experience the Class10 speed cards I suppose will fulfill all these timing requirements, and any BETTER brand will do the job. (there are some brands who just buy it from cheaper manufacturers and relabel it, even if they sound good, have no knowhow in this business)

I do not want to say that faster and more expensive is always better, but even the Sandisk Ultra 16GB SDHC cards can be <15 USD only, sooo... (probably microSD cards with an adapter will do the same job, even cheaper).

Posted By

MarkyPlus4
on 2018-01-25
13:23:55
 Re: SD2IEC Issue

Hi MMS, thankyou for your help and advice.

I have downloaded YAPE as an icon on the desktop, I will see if I can work this out
myself, and see if I can get a file to load okay.

Will be back to let you know how I get on

Regards

Marc

Posted By

MarkyPlus4
on 2018-01-25
13:58:23
 Re: SD2IEC Issue

Okay I have Plus4Emu as an icon on the desktop, I haven't got a clue what to do now,
I went to Tape heading, then load, but nothing happened when I selected the file?

Also how do you save a file to put onto an SD card to use with the SD2IEC?

Sorry for being dumb, but I have never used these emulators before.

Any help would be much appreciated

Marc

Posted By

Imperious
on 2018-01-26
08:49:39
 Re: SD2IEC Issue

All You need on the SD2IEC on the plus/4 is the filebrowser files in the root folder, then simply just create a folder called plus4 then copy the game files into that folder.
You can not play tape games on the SD2IEC, which is games that end in .tap
d64 and prg files should work ok.

Posted By

MarkyPlus4
on 2018-01-28
16:42:15
 Re: SD2IEC Issue

Thankyou Imperious, so I don't need to worry about YAPE, or Plus4emu,
at the moment, sorry but have been away on business the last few days, but will try this
out on Tuesday or Wednesday, and will let you all know how it all goes....

Regards

Marc

Posted By

MarkyPlus4
on 2018-01-31
04:08:12
 Re: SD2IEC Issue

Hi again, still no luck loading games with the SDIEC?

Tried another SD card, tried loading Kikstart, but the screen is just filled with
lots of $ signs, as if corrupt, and syntax error 2010 appeared?

Bit stumped on what to try next, any ideas here? Maybe there is a fault with the SD2IEC
I am wondering now

Cheers

Marc

Posted By

Csabo
on 2018-01-31
16:16:02
 Re: SD2IEC Issue

Hi Marc,

Have you eliminated the possibility that your Plus/4's RAM might be faulty? If not, I have a little program which will check the memory. (I wrote it for Baz a while back when he had a somewhat similar issue.) It would take a few minutes of typing, I guess; if you're up for it, here it is:

MONITOR
>600 78 8D 3F FF A9 55 8D 19
>608 FF A0 00 AD 5C 06 20 45
>610 06 AD 5B 06 20 45 06 A9
>618 FF 20 59 06 A9 AA 20 59
>620 06 A9 55 20 59 06 A9 00
>628 20 59 06 EE 5B 06 D0 03
>630 EE 5C 06 AD 5B 06 8D 63
>638 06 AD 5C 06 8D 64 06 C9
>640 FD D0 C6 F0 28 48 4A 4A
>648 4A 4A 20 50 06 68 29 0F
>650 AA BD 74 06 99 00 0C C8
>658 60 48 8D 00 08 A9 C9 8A
>660 98 68 CD 00 08 D0 01 60
>668 A9 32 8D 19 FF 8D 3E FF
>670 58 4C 45 F4 30 31 32 33
>678 34 35 36 37 38 39 01 02
>680 03 04 05 06
G600


When you run it, it will check pretty much the entire RAM. If any problems are found, the offending address will be left on screen and the border will turn red (otherwise it will be green). Maybe it's worth a shot.

Posted By

MarkyPlus4
on 2018-02-02
13:37:02
 Re: SD2IEC Issue

Hi Csabo,

Do I type this exactly as you have written with spaces,
and starting with the word MONITOR?

I am hoping this is not the RAM as I have recently had the Plus4
checked over by Mutant Catipillar.

Will let you know the outcome.

Thankyou for your help

Regards

Marc

Posted By

Csabo
on 2018-02-02
13:58:39
 Re: SD2IEC Issue

Yep, just like you said, type it in as-is. Looking forward to hearing your results!

Posted By

Markyplus4
on 2018-02-03
16:05:11
 Re: SD2IEC Issue

I am having problems writing the program.

Once I hit return on the first line, it comes up with other information about the computer?

Is this right, am I doing something wrong?

Regards

Marc

Posted By

Markyplus4
on 2018-02-03
16:10:29
 Re: SD2IEC Issue

Just typed MONITOR, press return to start next line, just comes up with MONITO?

Is this right, or do I have an issue here?

Regards

Marc

Posted By

Csabo
on 2018-02-03
17:49:32
 Re: SD2IEC Issue

Hi Marc,

When you first type MONITOR and press return/enter, it should display something like this:

MONITOR

PC SR AC XR YR SP
; 0000 00 00 00 00 F9

(The numbers will be something different, that's fine.)

You are now in "monitor mode" (as opposed to BASIC). In monitor mode, the Plus/4 understands different commands, e.g. the ">" command (as in the above list) will write some bytes directly to the memory. Also, in monitor mode, anything that the Plus/4 does NOT understand, will be answered with a "?" at the end of the line (as opposed to BASIC error messages, such as the well-known "?SYNTAX ERROR" and the like).

So... I think you're on the right track Once again, all you need to do, is type the all the lines from the above post, starting with the "MONITOR" line, and ending with the "G600" line, pressing return/enter at the end of each line.

Let me know how it goes

Posted By

MarkyPlus4
on 2018-02-04
19:03:25
 Re: SD2IEC Issue

Hi again, I have typed out the coding that you gave me, thanks

Don't think it's good, have a red border, and have an error in line 600, does
this definitely mean I have a RAM issue?

Will type it out again tomorrow to make sure, will get onto Mutant Caterpillar as they
should of sorted this out

Regards

Marc

Posted By

MarkyPlus4
on 2018-02-06
16:33:30
 Re: SD2IEC Issue

Hi Csabo,

I have tried typing out the program again, I still get a red background border,
with an error in the first line 600, is this definitely a RAM issue?

Best Regards

Marc

Posted By

Csabo
on 2018-02-07
09:36:05
 Re: SD2IEC Issue

Huh, I think something must have gone wrong here. The program starts checking from $0800 (which is why I wrote it checks most of the RAM, not all of it ), so it should not be able to give $0600 as the error... Is there any way you could take a photo of the screen?

Posted By

MarkyPlus4
on 2018-02-07
15:07:02
 Re: SD2IEC Issue

I will type it out again and show you wilth a photo

Posted By

Imperious
on 2018-02-08
09:05:35
 Re: SD2IEC Issue

I think I figured out the problem by typing this into VICE emulator.

The text you type after the monitor command needs to be lower case, not upper case

>600 78 8d 3f ff a9 55 8d 19
>608 ff a0 00 ad 5c 06 20 45
>610 06 ad 5b 06 20 45 06 a9
>618 ff 20 59 06 a9 aa 20 59
>620 06 a9 55 20 59 06 a9 00
>628 20 59 06 ee 5b 06 d0 03
>630 ee 5c 06 ad 5b 06 8d 63
>638 06 ad 5c 06 8d 64 06 c9
>640 fd d0 c6 f0 28 48 4a 4a
>648 4a 4a 20 50 06 68 29 0f
>650 aa bd 74 06 99 00 0c c8
>658 60 48 8d 00 08 a9 c9 8a
>660 98 68 cd 00 08 d0 01 60
>668 a9 32 8d 19 ff 8d 3e ff
>670 58 4c 45 f4 30 31 32 33
>678 34 35 36 37 38 39 01 02
>680 03 04 05 06
g600

Posted By

MarkyPlus4
on 2018-02-08
16:17:27
 Re: SD2IEC Issue

Hi there,

Sorry been busy the last couple of days, thanks for the info, I will try and
type it out again in lowercase over the weekend.

Will let you know what the outcome is....

Much appreciated

Marc

Posted By

Csabo
on 2018-02-09
08:05:27
 Re: SD2IEC Issue

Well... By default, there's no uppercase/lowercase issue on the Plus/4 - everything is uppercase. (You have to do something extra, specifically press C=+Shift to switch to the other mode.) I would have never imagined someone would do this - there's no reason to.

The default, correct way IMHO is to post / type everything in uppercase. To spell it out, that just means simply turning on the computer, and typing the letters as-is. When you type the very first "M" of the word "MONITOR", the keyboard has an uppercase "M" on it, and you press it without any modifiers (no shift, or C=, or control), so an uppercase "M" will appear on the screen as well.

Whew So, taking that into account, it should work

Posted By

Imperious
on 2018-02-10
07:17:09
 Re: SD2IEC Issue

Sorry if I have steered anyone the wrong way with this information.
I got the same behaviour that Markyplus4 is experiencing by pasting this into Vice
in upper case.

I wonder if His Shift lock key is turned on, or possibly stuck on?

Posted By

Markyplus4
on 2018-02-10
15:51:14
 Re: SD2IEC Issue

Hi Imperious,

I have got into lowercase no probes, by pressing commodore symbol and shift key, hope
you are sorted now?

How do you join the forum and post pictures?

I have typed the program and have got a green background, but on pressing return for each line
I got 0600, instead of >600?

Really need to post pics to explain what I mean.

Regards

Marc

Posted By

Csabo
on 2018-02-10
19:00:14
 Re: SD2IEC Issue

The easiest is to upload them to imgur.com, quick and free. Then you can post the URL here.

Otherwise, >600 will become >0600 when you're typing it in. Entering it either way is fine, it's the same, and I wanted to ensure you have less to type, so I omitted the leading zeroes.



Back to topReply To This Topic


Copyright © Plus/4 World Team, 2001-2018