Home  Search  Games  Tapes  Covers  Cheats  Maps  Software  New Stuff 
 Hall Of Fame  HVTC  Game Endings  Solutions  Remakes  Publications  Magazines  Effects  Top List 
 Members  Groups  Features  Plus/4 Encyclopedia  Hardware  Tools  Options  Forum 
Back to forumClick here to see the full topicGo to last reply

Posted By

on 2017-06-01
 Re: There is something (or bug?) about YAPE (1.1.2b).

As I mentioned above I understand the memory changing when switch to graphical screen, but why YAPE doesn't save (F8) the programs (using GRAPHIC instruction) with the normal starting address ($1001)? Why do I have to make a trick (GRAPHIC1:GRAPHIC0)?

"POKE44,16:RENUMBER" doesn't work!

I realised another interesting (or bug?) thing about YAPE...
When I prepared a pair of my programs (assembly.d64 and ted.d64) to upload this site, I wanted to make a disk (.d64) for them, because both consist of more files.

I checked the box of "Create empty" in the "File / Attach disk image..." but when I tried to ask for a DIRECTORY with F3, YAPE didn't show "the second ID" and showed "only 257 blocks free", what's more the colors were changed to a kind of gray.

In the end I made a copy of an exist disk image and formating it with:
OPEN 1, 8, 15, "N0:CHARLEMAGNE,00,2A"

...and now I have tried to make a disk image with x86 version of YAPE and it was all right, so the bug is in the x64 version!

Back to top

Copyright © Plus/4 World Team, 2001-2018